gtkpod

Tasklist

FS#68 - Cannot display iPhone contents

Attached to Project: gtkpod
Opened by John Frankish (frankish) - Saturday, 07 May 2011, 15:09 GMT+2
Last edited by phantomjinx (phantomjinx) - Tuesday, 18 June 2013, 22:56 GMT+2
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To No-one
Operating System Linux
Severity Medium
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Using git of 07 May 2011:

After mounting iPhone 3GS OS4.3.2 (not jailbroken) at /mnt/iphone with ifuse, gtkpod will not display contents (~/.gtkpod/prefs edited to change initial mount point) of iPhone.

using libgpod-0.8.0, libimobiledevice-1.0.6

$ gtkpod
Prepending /usr/local/lib/gtkpod to plugin directories
** Message: REMEMBERED PLUGINS
** Message: DEFAULT PROFILE /usr/local/share/gtkpod/data/default.profile
** Message: User profile /home/tc/.gtkpod/gtkpod.profile
Number of active plugins: 10
Segmentation fault

$ ls /mnt/iphone
ApplicationArchives/ Photos/ Safari/
Books/ Podcasts/ com.apple.dbaccess.lock
DCIM/ PublicStaging/ com.apple.itdbprep.postprocess.lock
Downloads/ Purchases/ com.apple.itunes.lock_sync
PhotoData/ Recordings/ iTunes_Control/

$ dmesg
...
usb 1-7: new high speed USB device using ehci_hcd and address 4
ipheth 1-7:4.2: Apple iPhone USB Ethernet device attached
usbcore: registered new interface driver ipheth
gtkpod[30457]: segfault at 5bc05bc ip b742b84c sp bfea9e08 error 6 in libc-2.11.1.so[b73bc000+13d000]
This task depends upon

Closed by  phantomjinx (phantomjinx)
Tuesday, 18 June 2013, 22:56 GMT+2
Reason for closing:  Not a bug
Additional comments about closing:  Suggest recompiling gtkpod or updating the underlying libs and gtkpo
Comment by John Frankish (frankish) - Tuesday, 10 May 2011, 08:59 GMT+2
If I use libimobiledevice-1.1.1 instead of libimobiledevice-1.0.6 and add a link libimobiledevice.so.1 -> libimobiledevice.so.2, then gtkpod will display the contents of the iPhone.

Note that the "please select your iPod" pop-up box does not close even after I select the iPhone and click "OK"
Comment by Christophe Fergeau (teuf) - Tuesday, 19 July 2011, 22:10 GMT+2
You should never ever create such symlinks, the names are different, and gtkpod refuses to pick a library with a different name on purpose, because the name change means the library authors wanted to indicate that the newer version isn't backward compatible with the older one.

Loading...